๐Ÿ” CVE Alert

CVE-2026-121652

MEDIUM 5.4

Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering

CVSS Score
5.4
EPSS Score
0.0%
EPSS Percentile
0th

Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.

CWE CWE-79
Vendor aws
Product maplibre-gl-js-amplify
Published Nov 3, 2026
Stay Ahead of the Next One

Get instant alerts for aws maplibre-gl-js-amplify

Be the first to know when new medium vulnerabilities affecting aws maplibre-gl-js-amplify are published โ€” delivered to Slack, Telegram or Discord.

Get Free Alerts โ†’ Free ยท No credit card ยท 60 sec setup

CVSS v3 Breakdown

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack Vector
Network
Attack Complexity
Low
Privileges Required
Low
User Interaction
Required
Scope
Changed
Confidentiality
Low
Integrity
Low
Availability
None

Affected Versions

AWS / maplibre-gl-js-amplify
0 < 4.0.3

References

NVD โ†— CVE.org โ†— EPSS Data โ†—
github.com: https://github.com/aws-amplify/maplibre-gl-js-amplify/releases/tag/v4.0.3 github.com: https://github.com/aws-amplify/maplibre-gl-js-amplify/security/advisories/GHSA-34v3-xxqp-g5g9 aws.amazon.com: https://aws.amazon.com/security/security-bulletins/2026-167-aws/