CVE-2026-116675
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
CVSS Score
0.0
EPSS Score
0.0%
EPSS Percentile
0th
TinyMCE is an open source rich text editor. From 7.9.3 until 7.9.4 and from 8.5.1 until 8.9.3, the media plugin creates elements crafted through data-mce-object in the active document before sanitization. Those elements can execute malicious scripts during processing, resulting in stored cross-site scripting for users with the media plugin enabled. This issue is fixed in versions 8.9.3 and 7.9.4.
| CWE | CWE-79 |
| Vendor | tinymce |
| Product | tinymce |
| Published | Oct 27, 2026 |
Stay Ahead of the Next One
Get instant alerts for tinymce tinymce
Be the first to know when new unknown vulnerabilities affecting tinymce tinymce are published โ delivered to Slack, Telegram or Discord.
Get Free Alerts โ
Free ยท No credit card ยท 60 sec setup
Affected Versions
tinymce / tinymce
>= 8.5.1, < 8.9.3 >= 7.9.3, < 7.9.4
References
github.com: https://github.com/tinymce/tinymce/security/advisories/GHSA-mf2p-h6hf-fcwm github.com: https://github.com/tinymce/tinymce/commit/bd1ab5ef024c648c3f9c0b409e54a6c227c7d8a2 github.com: https://github.com/tinymce/tinymce/releases/tag/8.9.3 tiny.cloud: https://www.tiny.cloud/docs/tinymce/7/7.9.4-release-notes/#overview tiny.cloud: https://www.tiny.cloud/docs/tinymce/latest/8.9.3-release-notes/#overview