๐Ÿ” CVE Alert

CVE-2026-115915

HIGH 8.1

vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

CVSS Score
8.1
EPSS Score
0.0%
EPSS Percentile
0th

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

CWE CWE-20 CWE-183
Vendor vllm-project
Product vllm
Published Oct 26, 2026
Last Updated Oct 26, 2026
Stay Ahead of the Next One

Get instant alerts for vllm-project vllm

Be the first to know when new high vulnerabilities affecting vllm-project vllm are published โ€” delivered to Slack, Telegram or Discord.

Get Free Alerts โ†’ Free ยท No credit card ยท 60 sec setup

CVSS v3 Breakdown

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector
Network
Attack Complexity
High
Privileges Required
None
User Interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Affected Versions

vllm-project / vllm
< 0.32.0

References

NVD โ†— CVE.org โ†— EPSS Data โ†—
github.com: https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h github.com: https://github.com/vllm-project/vllm/pull/60022 github.com: https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd github.com: https://github.com/vllm-project/vllm/releases/tag/v0.32.0