CVE-2026-111821
Apache ActiveMQ, Apache ActiveMQ KahaDB: Oversized client identifier strings poison the KahaDB journal
CVSS Score
0.0
EPSS Score
0.0%
EPSS Percentile
0th
Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB. A user can create a durable subscription with a clientId and subscription name that have a combined length > 65,535 (while separately being shorter) on a broker using KahaDB which can cause the broker to shutdown and be unrecoverable.ย This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
| CWE | CWE-20 |
| Vendor | apache software foundation |
| Product | apache activemq |
| Published | Nov 4, 2026 |
| Last Updated | Nov 4, 2026 |
Stay Ahead of the Next One
Get instant alerts for apache software foundation apache activemq
Be the first to know when new unknown vulnerabilities affecting apache software foundation apache activemq are published โ delivered to Slack, Telegram or Discord.
Get Free Alerts โ
Free ยท No credit card ยท 60 sec setup
Affected Versions
Apache Software Foundation / Apache ActiveMQ
6.0.0 < 6.3.3 0 < 5.19.12
Apache Software Foundation / Apache ActiveMQ KahaDB
6.0.0 < 6.3.3 0 < 5.19.12