๐Ÿ” CVE Alert

CVE-2026-105612

LOW 3.5

PostgreSQL Anonymizer: Data-modifying CTEs bypass the read-only restriction of masked roles

CVSS Score
3.5
EPSS Score
0.0%
EPSS Percentile
0th

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

CWE CWE-862
Vendor dalibo
Product postgresql anonymizer
Published Oct 28, 2026
Stay Ahead of the Next One

Get instant alerts for dalibo postgresql anonymizer

Be the first to know when new low vulnerabilities affecting dalibo postgresql anonymizer are published โ€” delivered to Slack, Telegram or Discord.

Get Free Alerts โ†’ Free ยท No credit card ยท 60 sec setup

CVSS v3 Breakdown

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Attack Vector
Attack Complexity
Privileges Required
User Interaction
Scope
Confidentiality
Integrity
Availability

Affected Versions

DALIBO / PostgreSQL Anonymizer
1 < 3.3.0

References

NVD โ†— CVE.org โ†— EPSS Data โ†—
gitlab.com: https://gitlab.com/dalibo/postgresql_anonymizer/-/issues/702

Credits

The PostgreSQL Anonymizer project thanks user Ilya Staroverov for reporting this problem.