CVE-2026-100300
Apache ZooKeeper: Unauthenticated persistent denial of service via unvalidated quota-node data and paths crashing the transaction-apply thread
CVSS Score
0.0
EPSS Score
0.0%
EPSS Percentile
0th
Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree โ unauthenticated on default deployments, where that subtree is world-writable โ to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.
| CWE | CWE-755 |
| Vendor | apache software foundation |
| Product | apache zookeeper |
| Published | Nov 4, 2026 |
Stay Ahead of the Next One
Get instant alerts for apache software foundation apache zookeeper
Be the first to know when new unknown vulnerabilities affecting apache software foundation apache zookeeper are published โ delivered to Slack, Telegram or Discord.
Get Free Alerts โ
Free ยท No credit card ยท 60 sec setup
Affected Versions
Apache Software Foundation / Apache ZooKeeper
3.9.0 โค 3.9.6 3.8.0 โค 3.8.7
References
Credits
๐ cunyi li <[email protected]>